Apphugs Community

Application Support => EchoHam => Topic started by: K1CGZ on April 16, 2016, 06:23:47 am

Title: Connection Issues
Post by: K1CGZ on April 16, 2016, 06:23:47 am
Downloaded V 2 today to my MacBook Pro running El Capitan.  I previously had EchoHam V 1 and EchoMac installed.  They used to work well.  With V 2, if I click on Server it loads a list, but when I click on a server, such as Echotest, and then click on connect the screen says, "connecting," then says, "disconnected" a few seconds later.  I tried a couple of repeaters and the Echlink test server.  They all start to connect, then disconnect.

I tried deleting EchoHam from my firewall permission list; then I reinstalled it on the list.  Still no connections.  What to do?
Title: Re: Connection Issues
Post by: support on April 16, 2016, 06:48:13 am
K1CGZ, do you still have EchoMac installed? Does it connect?
It looks very much like a Firewall issue, can you post details on what router you are using and copy of your firewall permission.
Title: Re: Connection Issues
Post by: K1CGZ on April 17, 2016, 04:07:34 am
EchoMac is still installed, however it does sort of the same thing.  It loads the repeater list.  I click on Echotest or a repeater; it says connecting.  It displays a server such as, "ECHOEC2-3: Herndon, VA USA."  Then apparently something times out.  It disconnects without ever having achieved connection to the destination.

The router is a ZyXEL.  If it has a firewall its news to me.  The only firewall that I have that I know of is in my MacBook.  I have EchoHam and EchoMac listed on my exception list on the firewall screen.  My iPad will connect through my router to the echo link system so I think my router and modem are working OK.
Title: Re: Connection Issues
Post by: support on April 17, 2016, 04:29:49 am
your problem is not with EchoHam or EchoMac.
Google "port forwarding ZyXEL" and you will find some videos to show you how it's done.
You need to forward UDP on ports 5198 and 5199 to your MacBook Pro.
Also look at ( for more information on port forwarding.

If you have previously used EchoHam then port forwarding would still be in place, but for whichever computer you have previously used and not for your MacBook Pro.

Hope this helps.
Title: Re: Connection Issues
Post by: K1CGZ on April 18, 2016, 01:45:55 am
OK, thanks for the insight.  I watched a couple of the YouTube videos, and I went into the admin screen for my router.  I found the port forwarding tab, but I didn't edit anything yet.  Additionally, I have a modem that is separate from my router.  The video I watched said that I might have to port forward in the modem as well as the router.  I also have the problem of watching these tutorials that are showing screen shots on Windows machines.  I then have to look at somewhat different views on my Mac so I can't follow cookbook style instructions.  I actually have to think about what I'm doing.  I will get there eventually, perhaps with a little help from my "hams running Macs" friends.  Once again, thanks for pointing me in the right direction.
Title: Re: Connection Issues
Post by: Jason Brambach on June 19, 2016, 07:15:29 am
I had trouble on a Mac but found help through a YouTube link.
Title: Re: Connection Issues
Post by: cavok on January 28, 2020, 06:35:15 pm
My understand is that port forwarding only works if you have a REAL IP on the external port of the router. Most ISPs and virtually all mobile ISPs provide a NAT solution with addresses like 192.xx or 10.x and can't be reached from outside.

What is the solution here? Echolink on an iPhone works fine.

Any thoughts?
Title: Re: Connection Issues
Post by: support on January 28, 2020, 10:54:01 pm
A "REAL IP" is a prerequisite at this stage.
However, a proxy server solution is in the making.
Unfortunately I can't provide a release date at this point in time.
Title: Re: Connection Issues
Post by: support on June 26, 2020, 09:16:21 pm
includes a number of connectivity improvements and tries to automatically configure your router for port forwarding.
The proxy server option is now implemented but at this stage you have to manually enter proxy server details.
In the near future I will include and automatic selection for public proxy servers.