Author Topic: EchoHam 2.13 Connection Issues  (Read 726 times)

philhowes

  • Regular
  • *
  • Posts: 7
    • View Profile
EchoHam 2.13 Connection Issues
« on: July 10, 2020, 03:31:09 AM »
Hello, I'm currently trying to use EchoHam 2.13  with MacOs 10.11.6 El Capitan.
I've registered with EchoLink and received confirmation. I can use the Android version on my tablet happily.

I start EchoHam and it downloads the callsign list, but I cannot connect to any repeater, link or callsign.

I've opened up ports 5198-99 on my router and forwarded them to my Mac (which has a static i.p)
I've created a Port Triggering with 5200 to open 5198-99.
I added EchoHam to the mac Firewall to allow incoming connections, and even tried with the firewall turned off.

I still cannot get EchoHam to connect to any repeater, link or callsign.

In the /applications/utilities/console app doing a search for EchoHam i get:

09/07/2020 18:16:42.974 EchoHam[4423]: EchoHam.EHPortmapping.startUPNPadd() - Unable to bind to upnp port 1900: Error Domain=NSPOSIXErrorDomain Code=48 "Address already in use" UserInfo={NSLocalizedDescription=Address already in use, NSLocalizedFailureReason=Error in bind() function}

09/07/2020 18:16:53.135 EchoHam[4423]: -[EHControlConnection _connectRemoteHost:] - timer started

any help would be greatly appreciated.

cheers Phil
« Last Edit: July 15, 2020, 07:57:23 AM by support »

support

  • Global Moderator
  • Jr. Member
  • *****
  • Posts: 82
    • View Profile
    • Apphugs
Re: EchoHam 2.13 Connection Issues
« Reply #1 on: July 10, 2020, 08:55:32 AM »
Hi Phil,
could you please advise your call sign so I can do some diagnostics from this end.

Thanks
« Last Edit: July 15, 2020, 07:57:38 AM by support »

philhowes

  • Regular
  • *
  • Posts: 7
    • View Profile
Re: EchoHam 2.13 Connection Issues
« Reply #2 on: July 10, 2020, 05:18:58 PM »
Hello,

My callsign is M7PHX

Thanks very much for your help

Cheers

Phil
« Last Edit: July 15, 2020, 08:00:45 AM by support »

support

  • Global Moderator
  • Jr. Member
  • *****
  • Posts: 82
    • View Profile
    • Apphugs
Re: EchoHam 2.13 Connection Issues
« Reply #3 on: July 10, 2020, 10:10:03 PM »
Hi Phil,
the console messages indicate that you have another application running which is hogging port 1900.
Do you have anything uPnP related installed?
Do you get the same console messages if run EchoHam straight after a reboot?
Any possibility that you have other software which could block EchoHam from port 1900?

« Last Edit: July 15, 2020, 07:57:47 AM by support »

philhowes

  • Regular
  • *
  • Posts: 7
    • View Profile
Re: EchoHam 2.13 Connection Issues
« Reply #4 on: July 13, 2020, 04:47:21 AM »
Hello, thanks for getting back to me. Unfortunately the same thing happens when I reboot. Also if I disable Upnp in Echoham it doesn't connect either. I can't find what's blocking port 1900. If I use netstat in the terminal and search for 1900 I get nothing?

cheers

Phil
« Last Edit: July 15, 2020, 08:00:33 AM by support »

support

  • Global Moderator
  • Jr. Member
  • *****
  • Posts: 82
    • View Profile
    • Apphugs
Re: EchoHam 2.13 Connection Issues
« Reply #5 on: July 13, 2020, 10:24:28 AM »
Phil, I noticed about 4 hours and 40 minutes after your last post our system shows you as working for both incoming and outgoing calls:
http://echolink.rossw.net/index.html?callsign=m7phx
Note the times are in UTC

Can you please let us know what you did to get it working?
« Last Edit: July 15, 2020, 08:00:20 AM by support »

philhowes

  • Regular
  • *
  • Posts: 7
    • View Profile
Re: EchoHam 2.13 Connection Issues
« Reply #6 on: July 13, 2020, 05:53:53 PM »
Hi,

I used my friends laptop, as a test on my router, which is running 10.13 High Sierra. So maybe its an issue with E capitan?

Cheers
« Last Edit: July 15, 2020, 08:00:10 AM by support »

support

  • Global Moderator
  • Jr. Member
  • *****
  • Posts: 82
    • View Profile
    • Apphugs
Re: EchoHam 2.13 Connection Issues
« Reply #7 on: July 14, 2020, 08:48:46 AM »
Thanks Phil,
it may be El Capitan or something else which is installed on your computer.

It would be great to hear from other users if they have the same issue with El Capitan.
« Last Edit: July 15, 2020, 08:00:00 AM by support »

philhowes

  • Regular
  • *
  • Posts: 7
    • View Profile
Re: EchoHam 2.13 Connection Issues
« Reply #8 on: July 14, 2020, 09:18:51 PM »
Hello,

using sudo lsof -i :1900 in the terminal told me that EyeConnect a UPnP streaming plugin for EyeTV 3 (an app for watching TV with a USB tv stick https://www.geniatech.eu/) was hogging port 1900 After disabling that it seems that I can connect now.


thanks very much
« Last Edit: July 15, 2020, 07:59:47 AM by support »

support

  • Global Moderator
  • Jr. Member
  • *****
  • Posts: 82
    • View Profile
    • Apphugs
Re: EchoHam 2.13 Connection Issues
« Reply #9 on: July 15, 2020, 07:57:03 AM »
Hi Phil,
many thanks for sharing your solution.

I have removed "El Capitan" from the subject name as the problem wasn't really related to El Capitan but EyeConnect and hence your solution would be applicable to other macOS versions.
« Last Edit: July 15, 2020, 07:59:37 AM by support »

philhowes

  • Regular
  • *
  • Posts: 7
    • View Profile
Re: EchoHam 2.13 Connection Issues
« Reply #10 on: July 15, 2020, 10:40:38 PM »
No worries, thanks for your help, yes that makes sense to remove El Capitan. I got there in the end. Great piece of software! At least now anyone else with connection issues might be able to rectify them easier.

Cheers

Phil

arandolp

  • Regular
  • *
  • Posts: 2
    • View Profile
Re: EchoHam 2.13 Connection Issues
« Reply #11 on: July 16, 2020, 01:28:13 PM »
Iíve latest Catalina and am experiencing similar problems with making connection. Any suggestions. I use my Verizon data plan so no router itís just through my phone.
EchoLink works wonderfully. I get good comments that I can be heard crystal clear.

I canít connect to anything. I also have Eye TV connect and I did the check. It doesnít say itís taking up
Any port. I run Activity Monitor as itís running in background but I donít have any eye tv device plugged in.

Also ran sudo lsof -i :1900                                                         
Password:
COMMAND     PID USER   FD   TYPE             DEVICE SIZE/OFF NODE NAME
EyeConnec 62829 root    7u  IPv4 0x492411d425993b9f      0t0  UDP 172.20.10.2:ssdp
EyeConnec 62829 root   14u  IPv4 0x492411d438ef9a2f      0t0  UDP 239.255.255.250:ssdp
Starpad@Starpad ~ %

Hereís what came up. Any ideas anyone? Thanks of your help.

Iím not sure how to disable a port as I run of my data plan on phone.

















arandolp

  • Regular
  • *
  • Posts: 2
    • View Profile
Re: EchoHam 2.13 Connection Issues
« Reply #12 on: July 16, 2020, 02:14:13 PM »
Hello,

using sudo lsof -i :1900 in the terminal told me that EyeConnect a UPnP streaming plugin for EyeTV 3 (an app for watching TV with a USB tv stick https://www.geniatech.eu/) was hogging port 1900 After disabling that it seems that I can connect now.


thanks very much


FYI

It's now EyeTV 4. They recently updated to a 64 bit app, but I hear it's garbage.

support

  • Global Moderator
  • Jr. Member
  • *****
  • Posts: 82
    • View Profile
    • Apphugs
Re: EchoHam 2.13 Connection Issues
« Reply #13 on: July 16, 2020, 05:33:53 PM »
Arandolp, what's your call sign?

philhowes

  • Regular
  • *
  • Posts: 7
    • View Profile
Re: EchoHam 2.13 Connection Issues
« Reply #14 on: July 16, 2020, 06:17:52 PM »
Iíve latest Catalina and am experiencing similar problems with making connection. Any suggestions. I use my Verizon data plan so no router itís just through my phone.
EchoLink works wonderfully. I get good comments that I can be heard crystal clear.

I canít connect to anything. I also have Eye TV connect and I did the check. It doesnít say itís taking up
Any port. I run Activity Monitor as itís running in background but I donít have any eye tv device plugged in.

Also ran sudo lsof -i :1900                                                         
Password:
COMMAND     PID USER   FD   TYPE             DEVICE SIZE/OFF NODE NAME
EyeConnec 62829 root    7u  IPv4 0x492411d425993b9f      0t0  UDP 172.20.10.2:ssdp
EyeConnec 62829 root   14u  IPv4 0x492411d438ef9a2f      0t0  UDP 239.255.255.250:ssdp
Starpad@Starpad ~ %

Hereís what came up. Any ideas anyone? Thanks of your help.

Iím not sure how to disable a port as I run of my data plan on phone.


Hello arandolp,

for me I went into my preferences in EyeTv and turned off sharing (see the screen grab) Uncheck those boxes and it will disable EyeConnect

Thanks, yes EyeTv4 is out, but its a paid upgrade, and I don't really use EyeTV much anymore.

cheers

Phil