Author Topic: EchoHam crashing on Connect  (Read 8529 times)

support

  • Newbie
  • *
  • Posts: 48
    • View Profile
    • Apphugs
EchoHam crashing on Connect
« on: May 30, 2014, 04:32:45 PM »
Some users have reported EchoHam crashing on "Connect".
I am unable to reproduce this problem on my iMac(s) / MacBookPro.

I am still looking for someone who can edit files in terminal to enable additional debugging and then email me the log files to determine which part of the code causes the crash.

If you can help please email me on support@apphugs.com

Laird

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: EchoHam crashing on Connect
« Reply #1 on: May 31, 2014, 02:20:17 AM »
On my iMac there's further trouble: the Activity Monitor reports it to be a CPU hog.

Baseline before clicking the EchoHam icon:
 172-178 processes
 740-760 threads
 98-99.5 idle CPU time

When I bring up EchoHam (from the dock) CPU time used goes like a roller coaster for ~30 seconds, then stabilizes at 78-79% occupied CPU (21% idle),  EchoHam is just sitting there - I'm not messing with it.

When I click "Online" the CPU-used stays at this 78% level.  Over the next 3 minutes usage sinks gradually to ~72%.  There are 8-10 echolinux threads.  None takes up any perceptible CPU time - only the EchoHam thread does.

When I hit clover-Q to take EchoHam down, the CPU time-used collapses back to ~1% ;on the very next sample, and stays there.

Do you have a runaway process inside the EchoHam app?  I've tried working inside several other apps while watching the Activity monitor  None I've tried so far takes more than 2-3% of CPU tme, and that only on transient basis.

support

  • Newbie
  • *
  • Posts: 48
    • View Profile
    • Apphugs
Re: EchoHam crashing on Connect
« Reply #2 on: May 31, 2014, 07:22:43 AM »
Hi Laird,
thanks for the additional information. It confirms my thoughts.

EchoHam uses a couple of subprocesses (echolinux and echoaudio), from the crash reports I can see that echolinux is the process that crashes. EchoHam detects the termination of echolinux and attempts to restart echolinux and that's why EchoHam uses up lots of CPU time when it continuously restarts the echolinux process. That's also why you see multiple echolinux processes where all but the last one have actually crashed.

The puzzle for me is why does echolinux crash on some systems?

Laird

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: EchoHam crashing on Connect
« Reply #3 on: June 01, 2014, 11:43:52 AM »
On my Mac LAN, at least, part of the cause may be un-configured ports on the local router.  I'm inside an Apple Extreme Airport device, which is in turn inside a Verizon FiOS router that separates Internet from telephone, then inside yet another Verizon router that separates Internet/telephone  from TV video. I can't get at a window in the Mac's router utility that looks anything like the window in the help file, so don't know what I must do to configure ports 5198-5200.  I have only the haziest idea what nature firewall I have.

The crash may be as simple as "no place to send outgoing UDP blocks".  In which case, perhaps if you put a fault sense in, that produces an ASCII diagnostic to the app screen, telling user that it's his fault things aren't going any further, and referring him with understated asperity to the help literature - rather than trying fruitlessly an infinite number of times to re-start echolinux... I in turn could send you a screen capture of what I see when I bring up the router utility and you
- tell me where I went wrong and tell me how simple it is to instead do the right thing
- add the Airport Exteme screen to the help file, with instructions for others who have the same router hardware

support

  • Newbie
  • *
  • Posts: 48
    • View Profile
    • Apphugs
Re: EchoHam crashing on Connect
« Reply #4 on: June 01, 2014, 07:11:27 PM »
Laird,
maybe the screenshot below helps with your router setup. It shows the port redirection required to run EchoHam.

« Last Edit: June 01, 2014, 07:13:25 PM by support »

Laird

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: EchoHam crashing on Connect
« Reply #5 on: June 02, 2014, 12:54:39 PM »
tnx - it helped, but I'm not home free.

Network-->Router Mode showed "Off (Bridge Mode)".  Airport Utility-->Help said to change mode to "DHCP and NAT".  When I did that, and clicked (+) below Port Settings, THEN I got the screen you sent.  Tnx.

The IP address was automatically filled in for the Mac.  It's apparently the within-LAN address: 10.0.1.201 rather than the external IP address: xxx.yyy.1.7 shown in the internet-->IPv4 Address pane of the Airport Server interface.  Not knowing any better, I left the 10.0.1.201 as it was.

When I clicked on Update, I got a diagnostic that an error had occurred, and that if I clicked "Forget", the device would be removed from the network.  So I did that, and the router avatar disappeared from the picture.  That was disconcerting, since the Airport Extreme box (and the LAN it contains/supports) is my gateway to the Internet.  By unplugging the router for 2 minutes and re-powering, I got operation back - in Off (Bridge Mode) again.  So near, and yet so far... What enhancement to my tactics-set do you suggest next?  BTW, today I acceded to router firmware-version update, from 7.6.1 to 7.6.4.  That at least seems to have gone well.

It seems that your wall-clock time lags mine (Dallas TX) by 9 hours (or precedes it by 15 :-) ).  I infer that you operate from eastern Australia.  I visited Sydney once, and Canberra, and the radio astronomy facility at Parkes.  Got to see a billabong pointed out to me.  Fond memories all.

I'm trying not to be a Gulaw - really I am...


support

  • Newbie
  • *
  • Posts: 48
    • View Profile
    • Apphugs
Re: EchoHam crashing on Connect
« Reply #6 on: June 02, 2014, 02:04:43 PM »
When I clicked on Update, I got a diagnostic that an error had occurred
 
 BTW, today I acceded to router firmware-version update, from 7.6.1 to 7.6.4.

Now that you have upgraded the Airport Extreme firmware, try again to add the port settings.

Laird

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: EchoHam crashing on Connect
« Reply #7 on: June 02, 2014, 02:14:21 PM »
I did.  It wasn't the old firmware, but that the auto-offered DHCP address for the Mac (the .201 last field) was outside the range 10.0.1.2 through 10.0.1.200 that the router was maintaining, and when I set that 201 field to 200 (and BTW added the port 5200 for both public and private TCP traffic) this time the router took it and came back green.  Yay!

So I brought up EchoHam.  This time, there are no echolinux threads - ergo, connect occurred within the ~3-second sampling time of the Activity monitor.  CPU usage is down below 4%.  So my conjecture that non-configured ports (and yours that the process inside EchoHam just kept beating its head against the wall) appear to both be solid.

But when I try to connect to something in the on-line list, EchoHam still crashes.  We're rid of the hang - my bad, and I've learned some Mac-101 along the way - but shirtsleeves stay rolled up for a bit longer.

What can I do next for you?  I'll be up another ~4 hours

Laird

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: EchoHam crashing on Connect
« Reply #8 on: June 02, 2014, 02:36:44 PM »
BTW: you say you find crash reports helpful.  The one from just now doesn't fit inside the 20k character max length of the allowed forum message.  I have it in my paste buffer, but don't know how to get it to you.

Now the router avatar is giving me flashing-amber, and the ASCII "double NAT" so when I went back in and set the trailing field back to 201, again the router took the edit with no problem (so what WAS the problem with the first submission?  Just leaving out the port-5200 TCP assignment??)


support

  • Newbie
  • *
  • Posts: 48
    • View Profile
    • Apphugs
Re: EchoHam crashing on Connect
« Reply #9 on: June 02, 2014, 02:43:52 PM »
BTW: you say you find crash reports helpful.  The one from just now doesn't fit inside the 20k character max length of the allowed forum message.  I have it in my paste buffer, but don't know how to get it to you.

As the first post in this thread states "please email me on support@apphugs.com

Now the router avatar is giving me flashing-amber, and the ASCII "double NAT" so when I went back in and set the trailing field back to 201, again the router took the edit with no problem (so what WAS the problem with the first submission?  Just leaving out the port-5200 TCP assignment??)

Not sure on that, a bit hard to diagnose from the other side of the world ???

Laird

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: EchoHam crashing on Connect
« Reply #10 on: June 02, 2014, 03:55:14 PM »
Thanks for hanging with me.

The full diagnostic message on the "double NAT" sum-up reads:

This Airport base station has a private IP address on its Ethernet WAN port.  It is connected to a device or network that is using NAT to provide private IP addresses.  Change your Airport base station from usingDHCP and NAT to bridge mode.

When I did that, the amber on the Airport avatar turned back green, and the "hang" and egregious CPU usage resumed.  The device referred to is almost certainly the Verizon router just upstream of mine - and its firmware is the intellectual property of my ISP - Verizon.  I sense that the solution to my problem will now involve the support department at the ISP shop.  They open for business in ~7 hours  ;)

Summing up (so far) here, I have no idea how to configure those ports without going into the DHCP and NAT mode on the Airport Extreme.  Your rendition of the app apparently requires that I do precisely that.  As the jocular mechanic said to the automotive customer, "We've isolated your problem.  The solution remains at large."

vk3bgs

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: EchoHam crashing on Connect
« Reply #11 on: June 09, 2014, 05:20:02 PM »
Just downloaded HechHam from the AppStore and having this problem.
The app crashes as soon as I either click on connect or use the enter key.
Have reset router ports but no different.
Using OS X 10.9.3 on iMac 27 inch 3.2 Ghz i5 with 9 GB 1600 Mhz DDR3

Denis VK3BGS

support

  • Newbie
  • *
  • Posts: 48
    • View Profile
    • Apphugs
Re: EchoHam crashing on Connect
« Reply #12 on: June 09, 2014, 10:09:24 PM »
Denis,
you may be able to help resolve this problem - please see http://forum.apphugs.com/index.php?topic=10.0 for details.
« Last Edit: June 09, 2014, 10:14:37 PM by admin »

Laird

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: EchoHam crashing on Connect
« Reply #13 on: June 13, 2014, 09:25:50 AM »
progress toward being able to  help:
1.  Verizon tech support will replace my gen-1 router with a gen-2 machine, free of charge.  I expect it to arrive in tomorrow's UPS.  I'll take the Airport Extreme (now daisy-chained to the Verizon box) out and configure the Verizon's ports as instructed.  I'll at least not have a "double NAT" diagnostic then.  I hope for better...

2. I'm coming up to speed on UNIX/OS-X.  I understand now the syntax of the commands you instructed be placed into the Mac system file.  By early next week I'll have a previous-purchase "sacrificial" iMac ready to serve as a test bench for using pico or vi (I have to install the capacitor-replacement kit therein first).  Assuming that goes well, I'll  be able to follow your instructions to send log files to you.  I'm hammered with other tasks through this weekend, but if you haven't fixed the bug by, say, Tuesday, I'll likely be in the game.

support

  • Newbie
  • *
  • Posts: 48
    • View Profile
    • Apphugs
Re: EchoHam crashing on Connect
« Reply #14 on: June 13, 2014, 09:35:49 AM »
not fixed yet, haven't received any debug output files as yet.
Look forward to receiving debug files.