Apphugs Community

Application Support => EchoHam => Topic started by: tnalpgge on December 12, 2015, 01:52:20 AM

Title: Registration difficulties with password
Post by: tnalpgge on December 12, 2015, 01:52:20 AM
This will be more of a bug report, since I eventually achieved a successful registration and login.  Though I think it may be useful to share what I learned along the way.  I am doing this from a Mac Pro, late 2013 model, running OS X 10.9.5.  EchoHam reports its version as 1.10 (840).

My first attempts to register (I am not logged in at this point, the system does not know my password yet!) involved a 16-character password that ended in a double-quote (").  The rest of the password did contain both capital and lowercase letters, numbers, and other punctuation symbols, but no whitespace.  The login process would simply hang until the client complained that it was not able to connect.  After I removed the double-quote things appeared to work normally.

To me this suggests:

Are there other reports of problems around password length, or specific password content?

I also discovered other authentication-related problems while attempting to debug this.  I would prefer to report them privately to a responsible party.  I can PGP encrypt if desired.
Title: Re: Registration difficulties with password
Post by: support on December 13, 2015, 09:19:41 AM
As far as I can see there is no limitation imposed on passwords on the client end.
Unfortunately there is no documentation available on the Echolink protocol, everything I know has come from studying the original EchoMac code.

In V1 of EchoHam server connection code is from the old EchoMac application, problems such as timeouts are not handled very well, V2 will have new code which addresses these issues.